nftl_format destroys the file system

Dvir Oren dvir at
Mon Mar 13 13:28:28 EST 2000

I tried nftl_format /dev/mtd0 49152 so that it won't destroy M-
Systems' firmware, and also tried formatting the flash entirely, and 
then putting the firmware on it using dd, but for some reason, after I 
boot the machine, the ext2 file system is destroyed.  If I check the 
file system before boot, everything is fine, and I can mount and 
umount and everything is there.  One thing I discovered is that 
when I run fdisk /dev/nftla, I get 1022 blocks, but when I format the 
flash with M-Systems' utilities, I get 999 blocks.

I will run somre more tests soon, but in the meantime, does 
anybody have any idea why this happens?

Of course, if the file system will work, and with the patched LILO I 
posted, and with a 2.3 kernel, I should be able to boot from the 
flash using MTD.

Dvir Oren <dvir at>
Lucid VON Ltd.     <>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

To unsubscribe, send "unsubscribe mtd" to majordomo at

More information about the linux-mtd mailing list