Anyone embedding RH 6.1 / 2.2.12 ?

Adi Linden adi at
Mon Dec 13 10:01:06 EST 1999

> >I was wondering if anyone has sucessfully "embedded" the 2.2.12 kernel
> >from the RedHat 6.1 distro...
> >2.0.36 worked fine but I am required to do an upgrade and there seems to
> >be quite a few differences.

Doing just. Took Redhat 6.1 and created minimal tar balls of packages.
Stribed binaries and libs and no docs, man pages, etc. It's up and running
including networking in an 8MB partition. df tells me it's consuming about

> >Currently, I can boot to the M-Systems chip as single user .  With a
> >normal boot, the login prompt shows but does not allow anyone, even
> >root, to login (I've copied the passwd, shadow, tons of library files
> >and pam.d stuff, but still no luck).

Compile util-linux, sysutils, shutils, ppp without PAM and shadow
password. Get's rid of a lot of libs. You can grab my work so far at:
No docs, though,except for some noted in 'FileList'...


To unsubscribe, send "unsubscribe mtd" to majordomo at

More information about the linux-mtd mailing list