[PATCH v2] mips: dts: ralink: mt7621: add cell count properties to usb

Justin Swartz justin.swartz at risingedge.co.za
Fri Mar 8 05:21:44 PST 2024


On 2024-03-08 14:01, Arınç ÜNAL wrote:
> On 8.03.2024 01:37, Justin Swartz wrote:
>> Add default #address-cells and #size-cells properties to the
>> usb node, which should be suitable for hubs and devices without
>> explicitly declared interface nodes, as:
>> 
>>    "#address-cells":
>>      description: should be 1 for hub nodes with device nodes,
>>        should be 2 for device nodes with interface nodes.
>>      enum: [1, 2]
>> 
>>    "#size-cells":
>>      const: 0
>> 
>> -- Documentation/devicetree/bindings/usb/usb-device.yaml
>> 
>> This version of the patch places the properties according to
>> the order recommended by:
>> 
>>     Documentation/devicetree/bindings/dts-coding-style.rst
>> 
>> Signed-off-by: Justin Swartz <justin.swartz at risingedge.co.za>
>> ---
>>   arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>> 
>> diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi 
>> b/arch/mips/boot/dts/ralink/mt7621.dtsi
>> index 5a89f0b8c..7532e17dd 100644
>> --- a/arch/mips/boot/dts/ralink/mt7621.dtsi
>> +++ b/arch/mips/boot/dts/ralink/mt7621.dtsi
>> @@ -289,10 +289,10 @@ usb: usb at 1e1c0000 {
>>   		reg = <0x1e1c0000 0x1000
>>   		       0x1e1d0700 0x0100>;
>>   		reg-names = "mac", "ippc";
>> -
>> +		#address-cells = <1>;
>> +		#size-cells = <0>;
>>   		clocks = <&sysc MT7621_CLK_XTAL>;
>>   		clock-names = "sys_ck";
>> -
> 
> Please keep the empty lines. It's easier to read. I don't see anything 
> on
> the Devicetree Sources (DTS) Coding Style that would restrict this.

The reason I removed them was due to the SoC DTSI example shown in [1]
lacking empty lines between properties, but then using them instead as
visual separation between properties and child nodes, or at least that's
how I understood it when I looked at it.

Personally, I prefer the look of the SoC DTSI example - but I don't mind
recreating the patch set with the empty lines between the properties 
left
entact.

As there is a mix of property spacing and ordering styles in mt7621.dtsi
already - what is the consensus on what a node in this file should look
like?

I also don't mind following that pattern and cleaning up the whole dtsi
according to that if it'll save us all time and energy in future.

Regards
Justin

[1] https://docs.kernel.org/devicetree/bindings/dts-coding-style.html



More information about the Linux-mediatek mailing list