[PATCH net-next v10 13/13] net: phy: mediatek: Remove unnecessary outer parens of "supported_triggers" var

SkyLake Huang (黃啟澤) SkyLake.Huang at mediatek.com
Mon Jul 1 21:25:31 PDT 2024


On Mon, 2024-07-01 at 12:20 +0100, Daniel Golle wrote:
>  	 
> External email : Please do not click links or open attachments until
> you have verified the sender or the content.
>  On Mon, Jul 01, 2024 at 06:54:17PM +0800, Sky Huang wrote:
> > From: "SkyLake.Huang" <skylake.huang at mediatek.com>
> > 
> > This patch removes unnecessary outer parens of "supported_triggers"
> vars
> > in mtk-ge.c & mtk-ge-soc.c to improve readability.
> > 
> > Signed-off-by: SkyLake.Huang <skylake.huang at mediatek.com>
> > ---
> > diff --git a/drivers/net/phy/mediatek/mtk-ge.c
> b/drivers/net/phy/mediatek/mtk-ge.c
> > index 90f3990..050a4f7 100644
> > --- a/drivers/net/phy/mediatek/mtk-ge.c
> > +++ b/drivers/net/phy/mediatek/mtk-ge.c
> > @@ -152,14 +152,14 @@ static int
> mt753x_phy_led_brightness_set(struct phy_device *phydev,
> >  }
> >  
> >  static const unsigned long supported_triggers =
> > -(BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> > - BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> > - BIT(TRIGGER_NETDEV_LINK)        |
> > - BIT(TRIGGER_NETDEV_LINK_10)     |
> > - BIT(TRIGGER_NETDEV_LINK_100)    |
> > - BIT(TRIGGER_NETDEV_LINK_1000)   |
> > - BIT(TRIGGER_NETDEV_RX)          |
> > - BIT(TRIGGER_NETDEV_TX));
> > +BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> > +BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> > +BIT(TRIGGER_NETDEV_LINK)        |
> > +BIT(TRIGGER_NETDEV_LINK_10)     |
> > +BIT(TRIGGER_NETDEV_LINK_100)    |
> > +BIT(TRIGGER_NETDEV_LINK_1000)   |
> > +BIT(TRIGGER_NETDEV_RX)          |
> > +BIT(TRIGGER_NETDEV_TX);
> 
> Those lines are added within the same series by patch 06/13
> ("net: phy: mediatek: Hook LED helper functions in mtk-ge.c").
> I get and like the idea of doing things one by one, but in this case
> instead of editing what you have just added, better move the commit
> removing the unnecessary parentheses somewhere before copying them to
> the mtk-ge.c driver in patch 6/13.
> 
> All the rest looks good to me now.

Indeed, I did this on purpose so that patch 13/13 will show that why
mtk-ge-soc.c's & mtk-ge.c's parens around "supported_triggers" var
needs to be removed. However, if this does cause problems for reviewing
and if there's next version for this series, I can move it to patch
6/13.

BRs,
Sky


More information about the Linux-mediatek mailing list