[PATCH net-next v10 13/13] net: phy: mediatek: Remove unnecessary outer parens of "supported_triggers" var

Daniel Golle daniel at makrotopia.org
Mon Jul 1 04:20:59 PDT 2024


On Mon, Jul 01, 2024 at 06:54:17PM +0800, Sky Huang wrote:
> From: "SkyLake.Huang" <skylake.huang at mediatek.com>
> 
> This patch removes unnecessary outer parens of "supported_triggers" vars
> in mtk-ge.c & mtk-ge-soc.c to improve readability.
> 
> Signed-off-by: SkyLake.Huang <skylake.huang at mediatek.com>
> ---
> diff --git a/drivers/net/phy/mediatek/mtk-ge.c b/drivers/net/phy/mediatek/mtk-ge.c
> index 90f3990..050a4f7 100644
> --- a/drivers/net/phy/mediatek/mtk-ge.c
> +++ b/drivers/net/phy/mediatek/mtk-ge.c
> @@ -152,14 +152,14 @@ static int mt753x_phy_led_brightness_set(struct phy_device *phydev,
>  }
>  
>  static const unsigned long supported_triggers =
> -	(BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> -	 BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> -	 BIT(TRIGGER_NETDEV_LINK)        |
> -	 BIT(TRIGGER_NETDEV_LINK_10)     |
> -	 BIT(TRIGGER_NETDEV_LINK_100)    |
> -	 BIT(TRIGGER_NETDEV_LINK_1000)   |
> -	 BIT(TRIGGER_NETDEV_RX)          |
> -	 BIT(TRIGGER_NETDEV_TX));
> +	BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> +	BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> +	BIT(TRIGGER_NETDEV_LINK)        |
> +	BIT(TRIGGER_NETDEV_LINK_10)     |
> +	BIT(TRIGGER_NETDEV_LINK_100)    |
> +	BIT(TRIGGER_NETDEV_LINK_1000)   |
> +	BIT(TRIGGER_NETDEV_RX)          |
> +	BIT(TRIGGER_NETDEV_TX);

Those lines are added within the same series by patch 06/13
("net: phy: mediatek: Hook LED helper functions in mtk-ge.c").
I get and like the idea of doing things one by one, but in this case
instead of editing what you have just added, better move the commit
removing the unnecessary parentheses somewhere before copying them to
the mtk-ge.c driver in patch 6/13.

All the rest looks good to me now.



More information about the Linux-mediatek mailing list