[PATCH v11 01/16] iommu/arm-smmu-v3: Refactor arm_smmu_setup_irqs

Will Deacon will at kernel.org
Wed Oct 7 07:06:47 PDT 2026


On Tue, Sep 29, 2026 at 03:44:55AM +0000, Pranjal Shrivastava wrote:
> @@ -5594,7 +5631,7 @@ static int arm_smmu_device_probe(struct platform_device *pdev)
>  	arm_smmu_rmr_install_bypass_ste(smmu);
>  
>  	/* Reset the device */
> -	ret = arm_smmu_device_reset(smmu);
> +	ret = arm_smmu_device_reset(smmu, false);

It's a minor thing, but I have an irrational dislike of 'bool' paramaters
because they're so opaque at the callsite. One way to tidy if up would
be to rename arm_smmu_device_reset() to __arm_smmu_device_reset() and
then have wrapper functions around that (e.g.
arm_smmu_device_reset_resume()) but I actually wonder wheter you need
the bool at all. Why can't you figure out the resume state from the 'struct
device' instead?

Will



More information about the linux-arm-kernel mailing list