[PATCH v2 0/9] arm64: stacktrace: unify unwind code

Catalin Marinas catalin.marinas at arm.com
Fri Dec 10 10:41:06 PST 2021


On Mon, 29 Nov 2021 14:28:40 +0000, Mark Rutland wrote:
> For historical reasons arm64 has a number of open-coded unwind functions. We'd
> like to unify these to reduce the amount of unwind code we have to expose, and
> to make it easier for subsequent patches to rework the unwind code for
> RELIABLE_STACKTRACE.
> 
> These patches unify the various unwinders using arch_stack_walk(). So that we
> can use arch_stack_walk() without having to expose /proc/${PID}/stack, I've
> picked Peter's patch decoupling ARCH_STACKWALK from STACKTRACE, which was
> previously posted at:
> 
> [...]

Applied to arm64 (for-next/stacktrace), thanks!

[1/9] arch: Make ARCH_STACKWALK independent of STACKTRACE
      https://git.kernel.org/arm64/c/1614b2b11fab
[2/9] arm64: Add comment for stack_info::kr_cur
      https://git.kernel.org/arm64/c/1e5428b2b7e8
[3/9] arm64: Mark __switch_to() as __sched
      https://git.kernel.org/arm64/c/86bcbafcb726
[4/9] arm64: Make perf_callchain_kernel() use arch_stack_walk()
      https://git.kernel.org/arm64/c/ed876d35a1dc
[5/9] arm64: Make __get_wchan() use arch_stack_walk()
      https://git.kernel.org/arm64/c/4f62bb7cb165
[6/9] arm64: Make return_address() use arch_stack_walk()
      https://git.kernel.org/arm64/c/39ef362d2d45
[7/9] arm64: Make profile_pc() use arch_stack_walk()
      https://git.kernel.org/arm64/c/22ecd975b61d
[8/9] arm64: Make dump_backtrace() use arch_stack_walk()
      https://git.kernel.org/arm64/c/2dad6dc17bd0
[9/9] arm64: Make some stacktrace functions private
      https://git.kernel.org/arm64/c/d2d1d2645cfd

-- 
Catalin




More information about the linux-arm-kernel mailing list