[PATCH v6 0/4] mmc: sdhci-of-arasan: Enable UHS-1 support for Keem Bay SOC

Ulf Hansson ulf.hansson at linaro.org
Wed Dec 2 05:53:42 EST 2020


On Wed, 2 Dec 2020 at 08:02, <muhammad.husaini.zulkifli at intel.com> wrote:
>
> From: Muhammad Husaini Zulkifli <muhammad.husaini.zulkifli at intel.com>
>
> Hello
>
> This patch series adds UHS-1 Support for Keem Bay SOC.
>
> Patch 1 : Add struct device *dev in probe func(),so that dev pointer can be widely use in probe to make code more readable.
> Patch 2 : Export function to be use by device driver to configure voltage rail output.
> Patch 3 : Defined the DT binding to support the UHS-1 operation.
> Patch 4 : Gives an overview of how voltage operations happen to support UHS-1 mode for Keem Bay SOC.
>
> All of these patches was tested with Keem Bay evaluation module board.
>
> Kindly help to review this patch set.

This version looks a lot better to me, but I am still requesting you
to model the pinctrl correctly. I don't see a reason not to, but I may
have overlooked some things.

Would you mind to re-submit to include the gpio/pinctlr list and the
maintainers, to get their opinion.

Kind regards
Uffe

>
> Thank you.
>
> Changes since v5:
> - Restructured voltage operation for io bus line in one function and added comments in sdhci-of-arasan.c.
> - Use gpio regulator modelling for expander pins.
> - Add DT Bindings for phys, vmmc and vqmmc supplies.
> - Renamed func name and added comments for firmware header files.
> - Update commit message for each patchs to describe what goes on.
>
> Changes since v4:
> - Fixed comment by Andy and Sudeep on first patch.
> - Add Acked-by tag.
> - Fixed comment by Michal and Andy on the third patch to replace current users of &pdev->dev.
>
> Changes since v3:
> - Add Dt bindings for uhs gpio.
> - Fixed comment by Michal and Sudeep on header file for the macro and error code.
> - Fixed comment by Andy and created 1 new patch to separate the struc dev pointer in probe func.
> - Fixed comment by Michal in arasan controller code.
>
> Changes since v2:
> - Removed Document DT Bindings for Keembay Firmware.
> - Removed Firmware Driver to handle ATF Service call.
> - Add header file to handle API function for device driver to communicate with Arm Trusted Firmware.
>
> Changes since v1:
> - Add Document DT Bindings for Keembay Firmware.
> - Created Firmware Driver to handle ATF Service call.
> - Provide API for arasan driver for sd card voltage changes.
>
>
> Muhammad Husaini Zulkifli (4):
>   mmc: sdhci-of-arasan: Add structure device pointer in probe func
>   firmware: keembay: Add support for Trusted Firmware Service call
>   dt-bindings: mmc: Add phys, vmmc and vqmmc supplies for Keem Bay SOC
>   mmc: sdhci-of-arasan: Enable UHS-1 support for Keem Bay SOC
>
>  .../devicetree/bindings/mmc/arasan,sdhci.yaml |   6 +-
>  drivers/mmc/host/sdhci-of-arasan.c            | 282 ++++++++++++++++--
>  include/linux/firmware/intel/keembay.h        |  54 ++++
>  3 files changed, 322 insertions(+), 20 deletions(-)
>  create mode 100644 include/linux/firmware/intel/keembay.h
>
> --
> 2.17.1
>



More information about the linux-arm-kernel mailing list