[PATCH 01/11] clocksource: arm_arch_timer: Rename arch_timer_probed to reflect behaviour
Ingo Molnar
mingo at kernel.org
Tue Mar 31 00:14:52 PDT 2015
* Daniel Lezcano <daniel.lezcano at linaro.org> wrote:
> From: Laurent Pinchart <laurent.pinchart+renesas at ideasonboard.com>
>
> The arch_timer_probed function returns whether the given time doesn't
> need to be probed. This can be the case when the timer has been probed
> already, but also when it has no corresponding enabled node in DT.
>
> Rename the function to arch_timer_need_probe and invert its return value
> to better reflect the function's purpose and behaviour.
>
> Acked-by: Sudeep Holla <sudeep.holla at arm.com>
> Signed-off-by: Laurent Pinchart <laurent.pinchart+renesas at ideasonboard.com>
> Signed-off-by: Daniel Lezcano <daniel.lezcano at linaro.org>
> ---
> drivers/clocksource/arm_arch_timer.c | 13 +++++++------
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/clocksource/arm_arch_timer.c b/drivers/clocksource/arm_arch_timer.c
> index a3025e7..50bb7f2 100644
> --- a/drivers/clocksource/arm_arch_timer.c
> +++ b/drivers/clocksource/arm_arch_timer.c
> @@ -661,17 +661,17 @@ static const struct of_device_id arch_timer_mem_of_match[] __initconst = {
> };
>
> static bool __init
> -arch_timer_probed(int type, const struct of_device_id *matches)
> +arch_timer_need_probe(int type, const struct of_device_id *matches)
If we do a rename we might as well use valid English spelling such as
'arch_timer_needs_probing()'?
Thanks,
Ingo
More information about the linux-arm-kernel
mailing list