[PATCH v4 07/19] PCI/MSI: Let pci_msi_get_domain use struct device's msi_domain

Bjorn Helgaas bhelgaas at google.com
Tue Jul 21 14:17:31 PDT 2015


Hi Marc,

On Wed, Jul 15, 2015 at 01:16:41PM +0100, Marc Zyngier wrote:
> Now that we can easily find which MSI domain a PCI device is
> using, use dev_get_msi_domain as a way to retrieve the information.
> 
> The original code is still used as a fallback.
> 
> Signed-off-by: Marc Zyngier <marc.zyngier at arm.com>
> ---
>  drivers/pci/msi.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/pci/msi.c b/drivers/pci/msi.c
> index ef4ec6e..c77fdaf 100644
> --- a/drivers/pci/msi.c
> +++ b/drivers/pci/msi.c
> @@ -41,7 +41,8 @@ static struct irq_domain *pci_msi_get_domain(struct pci_dev *dev)
>  {
>  	struct irq_domain *domain = NULL;
>  
> -	if (dev->bus->msi)
> +	domain = dev_get_msi_domain(&dev->dev);
> +	if (!domain && dev->bus->msi)
>  		domain = dev->bus->msi->domain;
>  	if (!domain)
>  		domain = arch_get_pci_msi_domain(dev);

I think this would be slightly easier to read as:

    struct irq_domain *domain;

    domain = dev_get_msi_domain(&dev->dev);
    if (domain)
	return domain;

    if (dev->bus->msi && (domain = dev->bus->msi->domain))
	return domain;

    return arch_get_pci_msi_domain(dev);

I'm not a huge fan of assignments inside "if" conditions, and checkpatch
might even complain about it, but it exposes the fallback order pretty well
here.  I guess we could also just repeat the dev->bus->msi->domain
expression:

    if (dev->bus->msi && dev->bus->msi->domain)
	return dev->bus->msi->domain;

We can at least get rid of the superfluous initialization of domain to
NULL.

Bjorn



More information about the linux-arm-kernel mailing list