[RFC PATCH 10/15] pwm: add the PWM initial state retrieval infra
Thierry Reding
thierry.reding at gmail.com
Mon Jul 20 02:01:24 PDT 2015
On Wed, Jul 01, 2015 at 10:21:56AM +0200, Boris Brezillon wrote:
> Add a ->init_state() function to the pwm_ops struct to let PWM drivers
> initialize the PWM state attached to a PWM device.
>
> Signed-off-by: Boris Brezillon <boris.brezillon at free-electrons.com>
> ---
> drivers/pwm/core.c | 3 +++
> include/linux/pwm.h | 2 ++
> 2 files changed, 5 insertions(+)
>
> diff --git a/drivers/pwm/core.c b/drivers/pwm/core.c
> index 3e830ce..30631f5 100644
> --- a/drivers/pwm/core.c
> +++ b/drivers/pwm/core.c
> @@ -264,6 +264,9 @@ int pwmchip_add_with_polarity(struct pwm_chip *chip,
> pwm->hwpwm = i;
> pwm_set_default_polarity(pwm, polarity);
>
> + if (chip->ops->init_state)
> + chip->ops->init_state(chip, pwm);
> +
> radix_tree_insert(&pwm_tree, pwm->pwm, pwm);
> }
>
> diff --git a/include/linux/pwm.h b/include/linux/pwm.h
> index 0f36a06..b47244a 100644
> --- a/include/linux/pwm.h
> +++ b/include/linux/pwm.h
> @@ -177,6 +177,8 @@ struct pwm_ops {
> struct pwm_device *pwm);
> void (*disable)(struct pwm_chip *chip,
> struct pwm_device *pwm);
> + void (*init_state)(struct pwm_chip *chip,
> + struct pwm_device *pwm);
I think I'd call this reset_state. init has this connotation of setting
a set of default values. For reset it's clearer in my opinion that it's
resetting to the hardware state.
Thierry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20150720/13fd205a/attachment.sig>
More information about the linux-arm-kernel
mailing list