[PATCH 1/8] PM / Runtime: Fetch runtime PM callbacks using a macro
Kevin Hilman
khilman at linaro.org
Wed Feb 26 10:50:03 EST 2014
Ulf Hansson <ulf.hansson at linaro.org> writes:
> While fetching the proper runtime PM callback, we walk the hierarchy of
> device's power domains, subsystems and drivers.
>
> This is common for rpm_suspend(), rpm_idle() and rpm_resume(). Let's
> clean up the code by using a macro that handles this.
>
> Cc: Kevin Hilman <khilman at linaro.org>
> Cc: Alan Stern <stern at rowland.harvard.edu>
> Cc: Greg Kroah-Hartman <gregkh at linuxfoundation.org>
> Cc: Mark Brown <broonie at kernel.org>
> Cc: Russell King <linux at arm.linux.org.uk>
> Cc: Linus Walleij <linus.walleij at linaro.org>
> Cc: Wolfram Sang <wsa at the-dreams.de>
> Cc: Alessandro Rubini <rubini at unipv.it>
> Signed-off-by: Ulf Hansson <ulf.hansson at linaro.org>
> ---
> drivers/base/power/runtime.c | 59 ++++++++++++++----------------------------
> 1 file changed, 20 insertions(+), 39 deletions(-)
>
> diff --git a/drivers/base/power/runtime.c b/drivers/base/power/runtime.c
> index 72e00e6..dedbd64 100644
> --- a/drivers/base/power/runtime.c
> +++ b/drivers/base/power/runtime.c
> @@ -13,6 +13,23 @@
> #include <trace/events/rpm.h>
> #include "power.h"
>
> +#define RPM_GET_CALLBACK(dev, cb) \
> +({ \
> + if (dev->pm_domain) \
> + callback = dev->pm_domain->ops.cb; \
> + else if (dev->type && dev->type->pm) \
> + callback = dev->type->pm->cb; \
> + else if (dev->class && dev->class->pm) \
> + callback = dev->class->pm->cb; \
> + else if (dev->bus && dev->bus->pm) \
> + callback = dev->bus->pm->cb; \
> + else \
> + callback = NULL; \
> + \
> + if (!callback && dev->driver && dev->driver->pm) \
> + callback = dev->driver->pm->cb; \
> +})
> +
> static int rpm_resume(struct device *dev, int rpmflags);
> static int rpm_suspend(struct device *dev, int rpmflags);
>
> @@ -310,19 +327,7 @@ static int rpm_idle(struct device *dev, int rpmflags)
>
> dev->power.idle_notification = true;
>
> - if (dev->pm_domain)
> - callback = dev->pm_domain->ops.runtime_idle;
> - else if (dev->type && dev->type->pm)
> - callback = dev->type->pm->runtime_idle;
> - else if (dev->class && dev->class->pm)
> - callback = dev->class->pm->runtime_idle;
> - else if (dev->bus && dev->bus->pm)
> - callback = dev->bus->pm->runtime_idle;
> - else
> - callback = NULL;
> -
> - if (!callback && dev->driver && dev->driver->pm)
> - callback = dev->driver->pm->runtime_idle;
> + RPM_GET_CALLBACK(dev, runtime_idle);
This macro sets the local 'callback' variable, but it's not at all
obvious when reading the code. macros with side-effects like this are a
major readability problem. Just use a function.
Kevin
More information about the linux-arm-kernel
mailing list