[PATCH v10 02/12] ARM/ARM64: KVM: Add common header for PSCI related defines

Ashwin Chaugule ashwin.chaugule at linaro.org
Mon Apr 28 10:19:14 PDT 2014

On 28 April 2014 13:13, Anup Patel <anup at brainfault.org> wrote:

>>> +#define PSCI_0_2_POWER_STATE_ID_MASK         0xffff
>>> +#define PSCI_0_2_POWER_STATE_ID_SHIFT                0
>>> +#define PSCI_0_2_POWER_STATE_TYPE_MASK               0x1
>> Shouldn't this be (0x1 << PSCI_0_2_POWER_STATE_TYPE_SHIFT)?
>> That seems to be the definition of a mask in the PSCI_VERSION_MAJOR_MASK
>> below, at least be consistent in this file.
> This was blindly adopted from Ashwin's patchset. I kept it this way so
> that it works for him. May be I should change this for consistency.
> I hope this will be fine for Ashwin ??

I dont have a problem changing it for consistency reasons.

The original code has it that way:


More information about the linux-arm-kernel mailing list