[PATCH v4 10/10] pwm-backlight: Add rudimentary device tree support
arnd at arndb.de
Thu Mar 15 04:48:32 EDT 2012
On Wednesday 14 March 2012, Thierry Reding wrote:
> + pwm = of_pwm_request(node, "pwm", 0);
> + if (IS_ERR(pwm))
> + return PTR_ERR(pwm);
It's interesting that the (so far) only user of of_pwm_request() doesn't
actually give a meaningful argument as the name of the pwm property.
Maybe rename that function to of_pwm_request_named() and provide a helper
that just does this:?
static inline struct pwm_device *of_pwm_request(struct device_node *np, int index)
return of_pwm_request_named(np, "pwm", index);
Any device that just has needs one pwm or uses more than one but has no
reason to name them can just use this helper then and use the default pwm
More information about the linux-arm-kernel