[PATCH 01/10] ARM: change ARM_DMA_ZONE_SIZE into a variable

Russell King - ARM Linux linux at arm.linux.org.uk
Fri Jul 8 16:30:45 EDT 2011

On Fri, Jul 08, 2011 at 01:14:41PM +0100, Russell King - ARM Linux wrote:
> It looks like ISA_DMA_THRESHOLD has become unused by most of the kernel,
> so yes, renaming it to "dma_zone_limit" would be more descriptive.  We
> should probably make dma_supported() be out-of-line anyway (which then
> means that dma_zone_limit doesn't have to be exported to drivers) - and
> I think the DMA bounce stuff needs cleaning up in dma_set_mask().

... and I now have a patch which does this, pending testing.  Once
I've tested it I'll send it out.

More information about the linux-arm-kernel mailing list