[RFC PATCH v2 1/4] dt: add of_get_child_number helper function
Dong Aisheng
b29396 at freescale.com
Wed Dec 14 11:03:39 EST 2011
From: Dong Aisheng <dong.aisheng at linaro.org>
Currently most code to get child number in kernel are almost same,
add a helper to implement this function for dt to use.
Signed-off-by: Dong Aisheng <dong.aisheng at linaro.org>
Cc: Grant Likely <grant.likely at secretlab.ca>
Cc: Rob Herring <rob.herring at calxeda.com>
---
include/linux/of.h | 17 +++++++++++++++++
1 files changed, 17 insertions(+), 0 deletions(-)
diff --git a/include/linux/of.h b/include/linux/of.h
index 4948552..09d53dc 100644
--- a/include/linux/of.h
+++ b/include/linux/of.h
@@ -189,6 +189,18 @@ extern struct device_node *of_get_next_child(const struct device_node *node,
for (child = of_get_next_child(parent, NULL); child != NULL; \
child = of_get_next_child(parent, child))
+static inline int of_get_child_number(struct device_node *np)
+
+{
+ struct device_node *child = NULL;
+ int num = 0;
+
+ while((child = of_get_next_child(np, child)))
+ num++;
+
+ return num;
+}
+
extern struct device_node *of_find_node_with_property(
struct device_node *from, const char *prop_name);
#define for_each_node_with_property(dn, prop_name) \
@@ -262,6 +274,11 @@ static inline bool of_have_populated_dt(void)
#define for_each_child_of_node(parent, child) \
while (0)
+static inline int of_get_child_number(struct device_node *np)
+{
+ return -ENOSYS;
+}
+
static inline int of_device_is_compatible(const struct device_node *device,
const char *name)
{
--
1.7.0.4
More information about the linux-arm-kernel
mailing list