[PATCHv5] atomic: add *_dec_not_zero

Benjamin Herrenschmidt benh at kernel.crashing.org
Sun Dec 4 17:41:55 EST 2011

On Sun, 2011-12-04 at 22:18 +0000, Russell King - ARM Linux wrote:


> And really, I believe it would be a good cleanup if all the standard
> definitions for atomic64 ops (like atomic64_add_negative) were also
> defined in include/linux/atomic.h rather than individually in every
> atomic*.h header throughout the kernel source, except where an arch
> wants to explicitly override it.  Yet again, virtually all architectures
> define these in exactly the same way.
> We have more than enough code in arch/ for any architecture to worry
> about, we don't need schemes to add more when there's simple and
> practical solutions to avoiding doing so if the right design were
> chosen (preferably from the outset.)
> So, I'm not going to offer my ack for a change which I don't believe
> is the correct approach.

I agree with Russell, his approach is a lot easier to maintain long run,
we should even consider converting existing definitions.


More information about the linux-arm-kernel mailing list