[RFC][PATCH] axi: add AXI bus driver

Rafał Miłecki zajec5 at gmail.com
Tue Apr 12 09:04:48 EDT 2011

2011/4/12 Rafał Miłecki <zajec5 at gmail.com>:
> Cc: Michael Büsch <mb at bu3sch.de>
> Cc: Larry Finger <Larry.Finger at lwfinger.net>
> Cc: George Kashperko <george at znau.edu.ua>
> Cc: Arend van Spriel <arend at broadcom.com>
> Cc: linux-arm-kernel at lists.infradead.org
> Cc: Russell King <rmk at arm.linux.org.uk>
> Cc: Arnd Bergmann <arnd at arndb.de>
> Cc: Andy Botting <andy at andybotting.com>
> Cc: linuxdriverproject <devel at linuxdriverproject.org>
> Cc: linux-kernel at vger.kernel.org <linux-kernel at vger.kernel.org>
> Signed-off-by: Rafał Miłecki <zajec5 at gmail.com>
> ---
> V2: Rename to axi
>    Use DEFINE_PCI_DEVICE_TABLE in bridge
>    Make use of pr_fmt and pr_*
>    Store core class
>    Rename bridge to not b43 specific
>    Replace magic 0x1000 with BCMAI_CORE_SIZE
>    Remove some old "ssb" names and defines
>    Move BCMAI_ADDR_BASE def
>    Add drvdata field
> V3: Fix reloading (kfree issue)
>    Add 14e4:0x4331
>    Fix non-initialized struct issue
>    Drop useless inline functions wrappers for pci core drv
>    Proper pr_* usage
> V3.1: Include forgotten changes (pr_* and include related)
>    Explain why we dare to implement empty release function

There is one more change I started to consider. Is "core" correct name
for AXI's device? Almost everywhere we can read about *components* on
the AXI interconnect.

Maybe it'd make sense to s/core/comp/? Arend?


More information about the linux-arm-kernel mailing list