[PATCH 4/7] ARM: oprofile: Move non-ARM code into separate init/exit
Robert Richter
robert.richter at amd.com
Wed Oct 6 14:44:07 EDT 2010
On 06.10.10 14:23:17, Grant Likely wrote:
> >> diff --git a/drivers/oprofile/oprof.c b/drivers/oprofile/oprof.c
> >> index b336cd9..76d97a5 100644
> >> --- a/drivers/oprofile/oprof.c
> >> +++ b/drivers/oprofile/oprof.c
> >> @@ -252,6 +252,8 @@ static int __init oprofile_init(void)
> >> {
> >> int err;
> >>
> >> + memset(&oprofile_ops, 0, sizeof(struct oprofile_operations));
> >> +
> >
> > Yes, this looks much better. Thanks Paul.
>
> oprofile_ops is allocated in bss and so is already zeroed. No need to
> do it explicitly.
Before oprofile_arch_init() it isn't necessarily needed, but we should
definitely add it before oprofile_timer_init(). For code readability I
would rather tend to let the first in too.
-Robert
--
Advanced Micro Devices, Inc.
Operating System Research Center
More information about the linux-arm-kernel
mailing list