[PATCH v11 2/6] mfd: khadas-mcu: Use MFD_CELL_* macros for cell declarations
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Wed Sep 2 05:58:57 PDT 2026
> From: Ronald Claveau <linux-kernel-dev at aliel.fr>
>
> Convert khadas_mcu_fan_cells[] and khadas_mcu_cells[] to use the
> MFD_CELL_NAME() helper macro instead of open-coding the struct
> mfd_cell initialisers. While at it, make both arrays const since
> they are never modified after initialisation.
>
> This is a pure cleanup with no functional change, done in
> preparation for a subsequent patch which will need to attach
> platform_data to the fan cell.
>
> Signed-off-by: Ronald Claveau <linux-kernel-dev at aliel.fr>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260902-add-mcu-fan-khadas-vim4-v11-0-5f1610d83bf0@aliel.fr?part=2
More information about the linux-amlogic
mailing list