[PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support
Xianwei Zhao
xianwei.zhao at amlogic.com
Thu Jul 9 02:31:43 PDT 2026
On 2026/7/9 16:35, sashiko-bot at kernel.org wrote:
> arm64: dts: amlogic: a9: Add reset controller support
>
> This commit adds reset controller descriptions for the Amlogic A9 SoC.
> It includes the corresponding reset IDs header and device tree nodes for
> both the main and ao reset controllers.
>
> [ ... ]
>
>> diff --git a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
>> --- a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
>> +++ b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
> [ ... ]
>
>> @@ -204,6 +212,12 @@ aobus: bus at ffa00000 {
>> #size-cells = <2>;
>> ranges = <0x0 0x0 0x0 0xffa00000 0x0 0x100000>;
>>
>> + ao_reset: ao-reset-controller at 2000 {
> [Severity: Low]
> Could this node use the generic name reset-controller at 2000 instead? Standard
> device tree schema validation expects reset controllers to match the generic
> pattern ^reset-controller(@.*)?$. Using ao-reset-controller at 2000 will likely
> trigger a validation warning when running make dtbs_check.
>
will use node-name reset-controller
>> + compatible = "amlogic,a9-ao-reset";
>> + reg = <0x0 0x2000 0x0 0xc>;
>> + #reset-cells = <1>;
>> + };
>> +
>> aobus_pinctrl: pinctrl at 4000 {
>> compatible = "amlogic,pinctrl-a9";
>> #address-cells = <2>;
More information about the linux-amlogic
mailing list