[PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Jul 9 01:35:49 PDT 2026
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The AO reset controller node uses a non-generic name 'ao-reset-controller at 2000' which fails standard schema validation.
--
--- Patch [3]: [PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support ---
commit 0f045fcc683de25785c6ca1a6df4d983c07bc9b4
Author: Xianwei Zhao <xianwei.zhao at amlogic.com>
arm64: dts: amlogic: a9: Add reset controller support
This commit adds reset controller descriptions for the Amlogic A9 SoC.
It includes the corresponding reset IDs header and device tree nodes for
both the main and ao reset controllers.
[ ... ]
> diff --git a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
> --- a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
> +++ b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi
[ ... ]
> @@ -204,6 +212,12 @@ aobus: bus at ffa00000 {
> #size-cells = <2>;
> ranges = <0x0 0x0 0x0 0xffa00000 0x0 0x100000>;
>
> + ao_reset: ao-reset-controller at 2000 {
[Severity: Low]
Could this node use the generic name reset-controller at 2000 instead? Standard
device tree schema validation expects reset controllers to match the generic
pattern ^reset-controller(@.*)?$. Using ao-reset-controller at 2000 will likely
trigger a validation warning when running make dtbs_check.
> + compatible = "amlogic,a9-ao-reset";
> + reg = <0x0 0x2000 0x0 0xc>;
> + #reset-cells = <1>;
> + };
> +
> aobus_pinctrl: pinctrl at 4000 {
> compatible = "amlogic,pinctrl-a9";
> #address-cells = <2>;
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260709-a9-reset-v1-0-fd7cf039b853@amlogic.com?part=3
More information about the linux-amlogic
mailing list