CMD22(CMD_802_11_DATA_RATE)failure problem

Cliff Cai xcahua at
Wed Sep 3 06:15:34 EDT 2008

>>> It'll show the data rate as 0 until you transmit or receive some frames,
>>> because the rate isn't actually known until (a) you've associated to
>>> something and (b) you've tx/rxed some frames.
>>> Setting the rate to auto shouldn't fail though, sounds like a bug. But
>>> this looks like it's fixed in 2.6.27, no error is returned.
>>> What's the git commit hash of the version of libertas you're using?
>>> 2.6.26 vanilla?
>>>> eth1 IEEE 802.11b/g ESSID:""
>>>> Mode:Managed Frequency:2.412 GHz Access Point: 00:00:00:00:00:00
>>>> Bit Rate:0 kb/s Tx-Power=18 dBm
>>>> Retry limit:8 RTS thr=2347 B Fragment thr=2346 B
>>>> Encryption key:off
>>>> Power Management:off
>>>> Link Quality:0 Signal level:0 Noise level:0
>>>> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
>>>> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>>>> I'm able to run:
>>>>>ifconfig eth1 up
>>>>>iwlist eth1 scan
>>>> and get the available AP information.
>>>> also I successfully run
>>>>>iwconfig eth1 essid myAPname
>>> Does the AP use any encryption? Does an "iwconfig" show a valid BSSID
>> It's exactly the encryption problem!
> Do you mean you've solved your issue? If you're using WEP there are
> quite a few gotchas, including the key length, the hashing algorithm
> (hex, passphrase, ascii) and the authentication system (open system or
> shared key) that you just have to know before trying to connect to a
> WEP-enabled AP.

Yes,at last I found an AP without encryption,so I successfully associated with it.
Everything is good except the bad performance,any suggestion about how to improve it?

>> One more question,I want to know if there is available firmware support SDIO SPI mode now?
>> I saw a post said it was not support that time ,how about now?
> Various parts have had G-SPI support for a while but of course that
> requires the firmware which people need to get form Marvell. If you've
> got firmware and the necessary host interface, we could try to give it a
> shot. But I have to admin I'm not familiar with how the host controller
> needs to be set up to handle SPI mode. Does it require a specific SDIO
> controller type, or can most SDIO controllers handle SPI? Does it
> require changes to the kernel SDIO stack to accommodate SPI? Basically,
> changes to the actual libertas driver aren't the only thing required
> here because I'm pretty sure we'd need changes to the host controller
> drivers and the stack too.

I have another board which has no SD host,but has a SPI bus.
AFAIK,Currently the G-SPI driver for Marvell 8686 is non-opensource,
I won't try it.Now there is a SPI simulated SD host driver in the kernel tree,see /drivers/mmc/host/mmc_spi.c
we've successfully tried it with a SD card,So I think SDIO SPI mode is a way to go,but I can't make it work.
that's why I ask this question.

Best Regards


More information about the libertas-dev mailing list