Marvell 88w8385 wlan adapter association problem, no AP details in scan

Marek Vašut marek.vasut at
Thu Jun 21 06:38:44 EDT 2007

Hi, Im not quite sure, but maybe you have so old card that you need to 
implement read-modify-write stuff? At least mine 8305 is stuffed by this ...

> Hi,
> I am porting ambicom-marvell 88w8385 wlan adapter host network driver from
> linux to pSOSystems. The original linux version host driver is getting all
> available Access Points details with scan request and getting associated
> with AP also, but my modified ported driver is not getting any AP details
> when it sends the scan request. But if i check the packets in the air with
> packet capture tool(wireshark), i could see the probe request from adapter
> and probe responses from  AP. What could be the problem? is probe response
> really comming inside firmware and firmware is not sending to host network
> driver? or firmware itself not receiving the probe response packets?
> I have tried the association also, but i am getting the status code as 2 in
> the response. I tried many times these test cases. but the result is same.
> Please anybody help me to solve this problem.
> Thanks & Regards,
> Prabhakar.
> _______________________________________________
> libertas-dev mailing list
> libertas-dev at

More information about the libertas-dev mailing list