[LEDE-DEV] questions about RB953GS on LEDE

Felix Fietkau nbd at nbd.name
Mon Jan 9 01:49:12 PST 2017

Hey Gui!

On 2017-01-09 01:09, Gui Iribarren wrote:
> So, I have two issues with porting LEDE to this mikrotik board
> (patch just sent in another thread)
> on one hand, console is not initialized properly in the default
> initramfs.elf
> the kernel cmdline is missing "console=ttyS0,115200", and so the console
> is disabled during boot.
> to workaround it, i did this:
> index 04e74d9..aa032c3 100644
> --- a/target/linux/ar71xx/mikrotik/config-default
> +++ b/target/linux/ar71xx/mikrotik/config-default
> @@ -133,7 +133,7 @@ CONFIG_ATH79_MACH_RBSXTLITE=y
>  # CONFIG_ATH79_MACH_ZCN_1523H is not set
>  # CONFIG_ATH79_NVRAM is not set
> -CONFIG_CMDLINE="rootfstype=yaffs noinitrd"
> +CONFIG_CMDLINE="rootfstype=yaffs noinitrd  console=ttyS0,115200"
>  CONFIG_GPIO_74X164=y
>  # CONFIG_JFFS2_FS is not set
> but clearly that's not upstreamable :P
> possibly i should update this file?
> target/linux/ar71xx/patches-4.4/701-MIPS-ath79-add-routerboard-detection.patch
> but since it's a patch, i guess i should use quilt (am i on the right
> track?)
Yes, that's exactly what you should do.

> on the other hand, the mtd partitions are apparently not being detected?
> (this is the first time i run openwrt/lede on a mikrotik)
> here's the complete bootlog, and the last two lines show only mtd0
> http://pastebin.com/uxRzvt0D
> while according to this
> https://wiki.openwrt.org/toh/mikrotik/common
> i should be seeing at least kernel and rootfs
> any pointers?
It's not an issue with partitions at all, the problem starts earlier:
The kernel does not detect any NAND flash device. If this thing is like
the other RouterBoard devices, you either need to use one of the
existing rb*_nand.c drivers, or (if they don't work) make a new one. For
that, you need to pass the appropriate platform data.
With a bit of luck, this one will be similar to the RB912 device that I
worked on yesterday, you might be able to copy some code from mach-rb91x.c.

By the way, the tree your work with for your changes should be my
staging tree:
In that tree, I've finished the conversion of ar71xx/mikrotik to UBI
yesterday, which simplifies handling of the NAND flash stuff a lot.

- Felix

More information about the Lede-dev mailing list