[LEDE-DEV] LEDE Reboot r1588+145 vs LEDE Reboot r1588+257 on TP-Link Archer C7 v2 / constant bootloop on 257

Břetislav Kubesa bretislav.kubesa at gmail.com
Sat Oct 22 14:08:11 PDT 2016


so I found out bootloop is caused by activation of Qualcomm Atheros 
QCA9880 802.11nac (radio1) - 5 GHz wireless.

I tried using QCA988x firmware as well as the CT modifications, but 
still it seems that with activation of ac radio, router goes to boot-loop.


So is the ath10k-firmware-qca988x broken maybe ?

Related config :

config wifi-device 'radio1'
     option type 'mac80211'
     option hwmode '11a'
     option path 'pci0000:01/0000:01:00.0'
     option htmode 'VHT80'
     option country 'US'
     option channel 'auto'
     option txpower '30'

config wifi-iface
     option device 'radio1'
     option network 'lan'
     option mode 'ap'
     option key 'password'
     option ssid 'aparcher'
     option encryption 'psk-mixed+ccmp'

Confirmed on LEDE Reboot r1588+365  as well.


Dne 16.10.2016 v 17:22 Břetislav Kubesa napsal(a):
> Hi,
> i tried to upgrade my TP-Link Archer C7 v2 from 145 to 257 and router 
> seems to be in constant reboot cycle. When I reset the config via 
> recovery, the router boots fine, currently I'm back on v145.
> Unfortunately I don't have serial (and AP is under warranty), so I 
> guess I can't investigate it (the network ping holds only like 5 secs, 
> not enough time for log......). I tried it flashing twice - same results.
> Using the same sources (but different config), others sets like 
> tl-mr3020-v1,-tl-wa850re-v1,tl-wr841-v11 etc. are absolutely fine.
> I know it's very vague description but any idea what could be causing 
> this between 145 and 257 versions ?
> My TP-Link Archer C7 v2 config if it helps : http://pastebin.com/zBeRpczT
> PS : Yes, I know I can start from scratch and see, when it broke 
> unfortunately I can't break internet connectivity except of night...
> PS2 : Reason I would like to update are random lost of Wifi 
> connectivity (I didn't investigate more yet, LEDs are blinking but 
> WiFi seems to be gone), versions prior to 145 were also fine.
> Thank you.
> Bretislav

More information about the Lede-dev mailing list