kdump kernel tried to load modules not included in the kdump initrd?

Jay Lan jay.zen.lan at gmail.com
Thu Jan 19 19:30:39 EST 2012

Hi Cong,

Thanks for your reply. It is good to know about lsinitrd. :)

I noticed that I ran out of memory during booting of 2nd kernel.
After I increased the crashkernel=xxx to 512M, it worked
correctly. Maybe OOM killed some processes and
things got confused... Anyway, it works now.


On 01/19/2012 04:26 AM, Cong Wang wrote:
> On Thu, 19 Jan 2012 at 07:46 GMT, Jay Lan<jay.zen.lan at gmail.com>  wrote:
>> Hi,
> Hi, Jay,
> This mailing list is not proper for reporting problems of distro's
> mkdumprd, please file a bug in bugzilla of centos.
>> I have a 2.6.32-131.6.1.el6 kernel, and kexec-tools-2.0.0-145.el6.x86_64
>> rpm on a cent6 machine.
>> When i forced a kdump by 'echo c>  /proc/sysrq-trigger',
>> the kdump kernel panicked during the boot. Surprisingly,
>> it tried to load lustre modules that should not be part of
>> the initrd and panicked!
>> The syslog showed the --initrd specified a kdump.img
>> when kdump was started. I dumped out the kdump.img
>> (with zcat) and verified that no lustre module was included
>> in the initrd image.
> lsinitrd can do that too.
>> So, how did this have happened?
> Odd, el6 mkdumprd picks all modules listed by lsmod in your *first
> kernel*, so it is not surprised mkdumprd picks it. But if it is not
> picked into kdump initrd, it is almost impossible that it will be
> loaded in the second kernel.
> _______________________________________________
> kexec mailing list
> kexec at lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/kexec

More information about the kexec mailing list