[PATCH 5/4] [-mm patch] Rename macros returning the size.
satyam at infradead.org
Thu Sep 20 08:21:42 EDT 2007
On Thu, 20 Sep 2007, Ken'ichi Ohmichi wrote:
> [PATCH 5/4] [-mm patch] Rename macros returning the size.
> The #define SIZE() should be renamed STRUCT_SIZE() since it's always
> returning the size of the struct with a given name. This would allow
> TYPEDEF_SIZE() to simply become SIZE() since it need not be used
> exclusively for typedefs. This idea is David Rientjes's.
> Ken'ichi Ohmichi
> Signed-off-by: David Rientjes <rientjes at google.com>
Hmm, I think adding a s-o-b line for David here isn't quite correct.
When someone reviews a patch and gives a suggestion, you only need to
copy him on the next iteration (and he may ack it or whatever, if he
wants) -- but adding a s-o-b line like that ends up (incorrectly)
denoting that he came between the author-to-git-commit chain ...
> Signed-off-by: Ken'ichi Ohmichi <oomichi at mxs.nes.nec.co.jp>
> --- a/include/linux/kexec.h 2007-09-18 15:22:19.000000000 +0900
> +++ b/include/linux/kexec.h 2007-09-18 15:23:22.000000000 +0900
> @@ -131,10 +131,10 @@ unsigned long paddr_vmcoreinfo_note(void
> vmcoreinfo_append_str("SYMBOL(%s)=%lx\n", #name, (unsigned long)&name)
> #define VMCOREINFO_SIZE(name) \
> vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> - (unsigned long)sizeof(struct name))
> -#define VMCOREINFO_TYPEDEF_SIZE(name) \
> - vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> (unsigned long)sizeof(name))
> +#define VMCOREINFO_STRUCT_SIZE(name) \
> + vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> + (unsigned long)sizeof(struct name))
> #define VMCOREINFO_OFFSET(name, field) \
> vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
> (unsigned long)&(((struct name *)0)->field))
Please use %zu and lose all the ugly (unsigned long) casts here.
Otherwise it looks good,
More information about the kexec