Half-open sockets

Flavius Lazar lazarflavius88 at gmail.com
Thu Jul 28 21:56:49 PDT 2016

Hello everyone,

I have an application that sends commands to wpa_supplicant through
the control interface. It provides simple functionality like scan,
connect to an AP or disconnect from an AP. This application runs on an
embedded Linux device.

I have a test that simulates the use case when my device passes out of
AP coverage exactly in the moment when it tries to connect to the AP.
I'm running this test in a loop and I noticed that I run out of open
file descriptors in my application's process. Checking with lsof I can
see a lot of sockets with "can't identify protocol". I do not open any
sockets in my application. So, I'm wondering if they might be from the
control interface part - there it uses unix domain sockets to send the
commands to wpa_supplicant?

I tried looking into the source code of wpa_supplicant, but it's not
so simple to identify what happens to the socket file descriptor if
the connection process is interrupted during the 4way handshake.

wpa_supplicant version: 2.0 (cannot upgrade - I have some patches from
my driver provider)

Best Regards,

More information about the Hostap mailing list