Initial connection problems

Thomas Schaaf thomas.schaaf
Sat Sep 1 13:24:38 PDT 2012

I am new to this mailing list so first and for most I wanted to thank
you all for providing such a great tool.

I am using hostapd to create an unencrypted wireless network (because
iwconfig wlan0 mode master does not work). On this machine I also have
an FTP Server running. For my camera I have the Canon WFT-E5 Adapter
[1] which provides the camera with the possibility to connect to a
provided WIFI Network and send images via FTP.
The setup works occasionally.
The first time I connect to the network I get an IP from the DHCP
Server (as seen in syslog & camera config) but I am unable to ping the
camera and it is unable to send me images. Sadly there are no log
files provided by canon except the error message "Cannot connect to
If I turn the camera off and on again it usually works (if the time
frame is not to far apart). And I am able to turn off the camera as
often as I want and pings from the server and images from the camera
go through.

Thus I have recorded the network traffic using tshark, hostapd output
and syslog: First connect after reboot of computer and camera
[2][3][4], Here I connect after having restarted hostapd. And then try
to turn the camera off and on until I get a connection on the ftp
server. [5][6][7], after restarting hostapd again the camera won't
connect again. [8][9][10]. My hostapd.conf [11], network settings [12]
is extremly simple.
Here is the longest log which captures me starting hostapd, restarting
the camera until it successfully connects and then restarting it a
couple more times. Turning off the camera and turning it back on after
a minute has passed. [13][14][15]

My setup in detail:
Debian Wheezy. I have also tried Debian Squeeze with the same results.
hostapd: 1.0.2
dhcp: isc-dhcp-server 4.2.2.dfsg.1-5
dns: bind9 9.8.1.dfsg.P1-4.2 ( I have tried dnsmasq aswell )
ip: server, camera, netmask,
iptables-save: is empty -> ALL ACCEPT
ipv6 is turned off through sysctrl.conf
wifi device: Asus PCE-N15 PC
wifi driver used: rtl8192ce

Canon 7D: Tried firmware 1.2 aswell as 2.0
Canon WFT-E5: 1.05 aswell as 1.07

To eliminate the DHCP Server and DNS Server are of no fault I have
first tried using dnsmasq aswell as setting the camera to manual IP
and tried the same procedure.

Sadly I am not able to reproduce the problem on any provided system.
Another machine using Debian can connect without any troubles and
connect to ftp the first time. I have tried the WFT Adapter in other
networks and it worked without a problem.

As stated before after the connection has been made once I am able to
turn off the camera as often as I want and the connection works
flawlessly. If I restart the hostapd service though the same error
Does anyone know what this problem could be linked to? Is there a solution?

I hope I have not "overprovided" information but would be happy to
provide any additional information needed.

Thank you very much for your time!

[1]: Wireless File Transfer Adapter WFT-E5:
[2]: Wireshark Fresh:
[3]: Hostapd Log Fresh:
[4]: Syslog Fresh:
[5]: Wireshark Camera reboot:
[6]: Hostapd Log Camera
[7]: Syslog Camera reboot:
[8]: Wireshark restart
[9]: Hostapd Log restart hostapd.
[10]: Syslog restart hostapd.
[11]: hostapd.conf:
[12]: Network settings:
[13]: Wireshark COMPLETE:
[14]: Hostapd Log COMPLETE:
[15]: SysLog COMPLETE:

Thomas Schaaf

Gesch?ftsf?hrer, Entwickler & B?rog?rtner

komola UG (haftungsbeschr?nkt)
Rebenring 33
38106 Braunschweig

Telefon: +49 531 3804200
Mobil: +49 176 27379788

Gesch?ftsf?hrer: Sebastian Hoitz, Thomas Schaaf
Amtsgericht Braunschweig | HRB 201595

More information about the Hostap mailing list