p2p_group_add failed to initialize group interface

Jouni Malinen j
Mon Nov 19 02:03:19 PST 2012

On Sun, Nov 18, 2012 at 08:08:20PM -0600, Chao Xu wrote:
> I'm running the latest wpa_supplicant. My wireless adapter uses ar9170
> chipset. I installed the carl9170 driver. When I tried the p2p_gorup_add,
> the wpa_cli returned this:
> p2p_group_add
> <5>P2P: Failed to initialize group interface

It looks like the driver rejected this configuration for some reason. I
have not tested P2P with carl9170, so I don't know what to expect from

> nl80211: Create interface iftype 9 (P2P_GO)
> nl80211: New interface p2p-wlan0-0 created: ifindex=10
> nl80211: Allocate new address for P2P group interface
> nl80211: Assigned new P2P Interface Address 02:1f:33:f8:0f:23
> P2P: Created pending virtual interface p2p-wlan0-0 addr 02:1f:33:f8:0f:23

> Could not set interface p2p-wlan0-0 flags (UP): Device or resource busy
> nl80211: Could not set interface 'p2p-wlan0-0' UP

> What's the possible reason that prevents the setup of the interface
> p2p-wlan0-0? I turned off the network-manager when I run wpa_supplicant to
> prevent any interference. Thank you!

Do you need support for concurrent operations (station + P2P interface
at the same time)? If not, you could test what happens if you disable
use of a separate group interface by adding this to wpa_supplicant
configuration file:
Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list