p2p_group_add failed to initialize group interface

Chao Xu caesarxuchao
Sun Nov 18 18:08:20 PST 2012

Hi Jouni,

I'm running the latest wpa_supplicant. My wireless adapter uses ar9170
chipset. I installed the carl9170 driver. When I tried the p2p_gorup_add,
the wpa_cli returned this:
<5>P2P: Failed to initialize group interface

Here is what the log says:
wlan0: Control interface command 'P2P_GROUP_ADD'
P2P: Stop any on-going P2P FIND
wlan0: P2P: Stopping find
wlan0: P2P: Clear timeout (state=IDLE)
wlan0: P2P: State IDLE -> IDLE
P2P: Set GO freq 2412 MHz (no preference known)
nl80211: Get shared freq for PHY phy0
nl80211: No shared interface for PHY (phy0) in associated state
P2P: Create a new interface p2p-wlan0-0 for the group
nl80211: Create interface iftype 9 (P2P_GO)
nl80211: New interface p2p-wlan0-0 created: ifindex=10
nl80211: Allocate new address for P2P group interface
nl80211: Assigned new P2P Interface Address 02:1f:33:f8:0f:23
P2P: Created pending virtual interface p2p-wlan0-0 addr 02:1f:33:f8:0f:23
Initializing interface 'p2p-wlan0-0' conf 'N/A' driver 'nl80211'
ctrl_interface '/var/run/wpa_supplicant' bridge 'N/A'
nl80211: interface p2p-wlan0-0 in phy phy0
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
Could not set interface p2p-wlan0-0 flags (UP): Device or resource busy
nl80211: Could not set interface 'p2p-wlan0-0' UP
netlink: Operstate: linkmode=0, operstate=6
nl80211: Set mode ifindex 10 iftype 2 (STATION)
p2p-wlan0-0: Failed to initialize driver interface
Failed to add interface p2p-wlan0-0

What's the possible reason that prevents the setup of the interface
p2p-wlan0-0? I turned off the network-manager when I run wpa_supplicant to
prevent any interference. Thank you!

Chao Xu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20121118/824505ac/attachment.htm 

More information about the Hostap mailing list