Is WPS supported on Linux systems using the wext driver?

Charles Gordon digigordo
Fri Oct 7 14:51:11 PDT 2011


I'm trying to find out if wpa_supplicant can support WPS on an
embedded Linux system.  I built it with "CONFIG_WPS=y" in the .config
file and tried running it with this configuration file:


## -- Example MANAGED network

I tried both the 6.10 and 7.3 versions.  However, when I run it I get
these errors:

Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver
'wext' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line: 5 - start of a new network block
Line 6: invalid proto 'WPS'
Line 6: no proto values configured.
proto: 0x0
Line 6: failed to parse proto 'WPS'.
Line 7: unknown EAP method 'WPS'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
eap methods - hexdump(len=16): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Line 7: failed to parse eap 'WPS'.
Line 8: WPA-PSK accepted for key management, but no PSK configured.
Line 8: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
Failed to add interface wlan0
Cancelling scan request
Cancelling authentication timeout

The documentation isn't clear (to me) about whether WPS is supported
by wpa_supplicant, and looking at the code it appears that it is only
supported by the NDIS driver.

Is there a way to support WPS with the standard WEXT driver?

Thanks for your help.

More information about the Hostap mailing list