Can't use virtual interface for P2P connection

Lin Ma linmaonly
Mon Jan 10 10:33:32 PST 2011

Hello Jouni,

Thanks a lot for replying to this. I use the latest code checked out by git
clone git:// Which version is known to work?


On Fri, Jan 7, 2011 at 2:49 AM, Jouni Malinen <j at> wrote:

> On Thu, Jan 06, 2011 at 04:57:34PM -0800, Lin Ma wrote:
> > Have you ever tried to enable "-p
> driver_param=use_p2p_group_interface=1"? I
> > tested P2P with virtual interface enabled on a ath9k setup, the
> > wpa_supplicant printed out the following error messages and failed to
> > connect to the other peer.
> Yes and it worked the last time I tested.
> > Could not set interface p2p-wlan0-0 flags: Name not unique on network
> Which wpa_supplicant version are you using? It looks like that version
> did now show "nl80211: Assigned new P2P Interface Address" message in
> the debug log, so maybe it does not include all the changes in
> allocating a unique MAC address for the interface.
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list