Intersil prism 2.5 && WPA

Frank Hartmann soundart
Sat Apr 3 03:14:27 PDT 2010


I have problems connecting to my WLAN with my laptop.  I am running
debian/squeeze and tried all variations of things I could find.

The last time it was working was around debian etch and the bits of
configuration which were left over seem to indicate I was using hostap
and hostap_pci as kernel module and a tool called wpa_supplicant for
other things in user space. I had to blacklist some other drivers,
because there were multiple drivers for this chipset.

Nowaday in debian squeeze it seems, that I can still use the kernel
modules, but cannot configure wpa_supplicant to use them.

I tried then several live CDs with no good results.

Fedora-12-i686-Live.iso: I could not connect using a GUI called Network
Manager, it offered only WEP support, and some other stuff, but no WPA

ubuntu-9.10-desktop-i386.iso: exactly the same as fedora: Same tool,
same options, WPA seems missing. The kernel modules loaded were hostap,
hostap_pci, orinoco, orinoco_pci. I was able to connect to my WLAN using
this life CD and another laptop with  a different chipset. There a
choice "personal WPA" was visible.

KNOPPIX_V6.2.1CD-2010-01-31-EN.iso: Same Network Manager GUI, but no
wireless networks were shown. The kernel module used was orinoco_pci and
I found a kernel crash related to this module in the output of dmesg.

So I was wondering :

Is someone still using this chipset in combination with WPA and could
direct me in the right direction?

Or if I am the only one left with old hardware, is there a good place to
start for debugging this a bit more? Is someone intersted in more details
with respect to one of the listed setups, please? 

kind regards

More information about the Hostap mailing list