association results with mgmt::unknown error

Kevin Wilson wkevils
Mon Feb 2 11:42:31 PST 2009

I am trying to use an rt73 driver as an access point with hostapd.
I am using the most recent git hostapd source and the most recent
wireless-testing git tree.

  I start hostapd successfully. I am not using any encryption at the moment.
(not any wpa_supplicant).
I am able to see the hostapd AP by scanning from a nearby machine.

When I try association and authentication by running from that nearby machine,
I get this error in the hostapd logs (on stdout):

I tried this by running:
iwconfig wlan1 essid APEssid ap macAP
where APEssid is the essid of the ap and macAP is the mac address of the AP
(I see these values also in the scan result)

And I see later by iwconfig, that I am not associated to the AP which
runs hostapd.

I added some print messages and traced this error to the hostapd sources:
ieee802_11_mgmt() in  ieee802_11.c.
As far as I understand, the type should be association request (
WLAN_FC_STYPE_ASSOC_REQ) since an association request was sent.

Any idea why this error ? I must say that I tried setting the channel
to different
values (1,6,10,12) and got the same error.

The driver on the client is also rt73.

Kevin Wilson

More information about the Hostap mailing list