Problem with RTL8187B USB stick

Iñigo Martínez inigomartinez
Mon Feb 2 10:02:25 PST 2009

Hash: SHA1

Pavel Roskin escribi?:
> On Tue, 2009-01-27 at 01:16 +0100, I?igo Mart?nez wrote:
>> Hash: SHA1
>> Hello:
>> I'm having some problems with an wireless USB stick. In the last months
>> i was thinking that the driver wasn't mature enough and that was why it
>> wasn't working, but lately i got a new laptop, tried with it and it was
>> working. Both are configured the same afaik.
>> This are tries done with 2.6.28-r1 kernel. I have tried with 2.6.29-rc2
>> without any luck neither. I'm lately out of ideas.
>> Anyway, i'm sending the mandatory information (sorry for the huge
>> message). "Please" ask me for anything more i can provide.
> I could not reproduce this problem with the current kernel from
> wireless-testing.git, and the current wpa_supplicant.  It's also using
> rtl8187b:
> [ 8796.253071] rtl8187 1-6:1.0: usb_probe_interface
> [ 8796.253078] rtl8187 1-6:1.0: usb_probe_interface - got id
> [ 8796.513123] rtl8187: 8187B chip detected.
> [ 8796.516324] wmaster0 (rtl8187): not using net_device_ops yet
> [ 8796.517114] phy0: Selected rate control algorithm 'minstrel'
> [ 8796.523697] phy0: hwaddr 00:14:d1:45:a9:0b, RTL8187BvE V0 + rtl8225z2
> [ 8796.523810] usbcore: registered new interface driver rtl8187
> The difference is that I'm using WPA2 and CCMP on the AP.
> I suggest removing ap_scan=1.  You may also want to check all
> differences between two machines.  Try using the same device on both of
> them.  Try using another AP.

Thank you Pavel:

I have tried with the first livecd I got around, an 8.10 Ubuntu. In the
laptop it was working correctly. I have tried in this one and it wasn't
working. The livecd is the same in both so, the problem isn't in the os
or the configuration.

I don't know where to look now. Maybe the hardware is failing ?. But the
rest of the hardware is working correctly, and I have two USB
controllers (VIA (UHCI and EHCI) and SiS (OHCI)). Maybe the problem is
with the driver or the Wireless architecture in the kernel. I will ask

Any idea that could bright this darkness ?

Thank you again,

Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the Hostap mailing list