nl80211: Failed to enable userspace MLME, (ath5k)

Ahmad Ali Tabassam ahmadthe8
Sun Nov 23 06:09:30 PST 2008

> As I now allnew mac80211 based drivers are supported with hostapd's nl80211driver. b43 (Broadcom chipset; bcm4318)supports AP, ad-hoc, mesh and full monitor modes. ?The ath5k (Atheros chipset; AR5212) also supports AP, ad-hoc and mesh as well.

> But for both configurations to use FT-PSK I got almost the same error. Authentication (Open) goes successfully between STA and AP but the association always fails. hostapd.conf, wpa_supplicant.conf and log files are attached. Can anyone guide me, how can I overcome the error???.and alos Please would you tell me on which chipset did you test the wpa_supplilcant and hostpad support for 802.11r.

You are actually not using userspace MLME due to a typo on the command
line. The driver parameter is use_mlme, not usemlme (i.e.,
-puse_mlme=1). In addition, you will need to replace the wext driver
wrapper with nl80211 (-Dnl80211) in order to be able to use userspace
MLME with the current mac80211 version (with the two extra patches).

I verified that I can complete the initial association with your
configuration files once replace the wpa_supplicant arguments:
wpa_supplicant -dd -Dnl80211 -iath0 -puse_mlme=1 -c wpa_supplicant.ft_psk.conf

I tested this with ath9k in the AP and ath5k in the client, but I would
expect any other supported mac80211 driver to work here, too.

Jouni Malinen? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? PGP id EFC895FA

Hello Jouni Malinen, 
Thanks for your all guidence and kind help
Jouni I need little more help?I am facing an other problem, driver_nl80211 works fine for hostapd,
But for wpa_supplicant 0.6.5
For? my wirless-testing2.6.28-rc4-wl with the following patch.
libnl1.1 etc.

I? used NL_80211 for wpa_supplicant 0.6.5 (rest are defult)
CFLAGS += -I$(LIBNL)/include
LIBS += -L$(LIBNL)/lib
CFLAGS += -I$(WIRELESS_DEV)/net/mac80211

when I run # wpa_supplicant -dd -Dnl80211 -iwlan2 -puse_mlme=1 -c wpa_supplicant.ft_psk.conf
either for ath5k or ath9k, it always fails. I get the following detail in the last.
Failed to set interface wlan2 mode
Could not configure driver to use managed mode
nl80211: Using user space MLME
nl80211: Failed to enable userspace MLME

Few days back when I was trying hostapd if I use hw_mode=b I had the almost same error. 
Hardware does not support configured mode
wlan2: IEEE 802.11 Hardware does not support configured mode (0)
Could not select hw_mode and channel. 
It was resoved using the hw_mode=g

This is a driver_nl80211 problem, How this problem can be resolved for wpa_supplicant. 
lspci -k, shows me the the driver ath5k is enabled. iwconfig shows me wlan2 is using a Managed mode.
I have goen throug driver_nl80211.c source code. I can see there are two mode Ad-Hoc and STATION.
I think the Managed and STATION modes are two different name for Infrastructure mode.
Why It fails for wpa_supplicant, and why I can not enable the use_mlme mode.
Any idea,

Best Regards 

Ahmad Ali Tabassam
Institute Industrial IT
Dept. of Electrical Engineering and Computer Science

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list