EAP-Success = failure?

Adamson, Ryan M. adamsonrm
Mon Jan 14 09:40:20 PST 2008

I'm using compiled source from the latest stable release: 0.5.9 I
believe.  I can connect using wpa_supplicant to unencrypted and
WEP-secured access points.  I ran into this problem a few months ago and
had to put it down due to lack of free time.  I can't remember which
release I was using then, but I was also able to connect to WPA-PSK
networks.  I haven't tried to connect to a PSK network recently, though.


-----Original Message-----
From: Dan Williams [mailto:dcbw at redhat.com] 
Sent: Friday, January 11, 2008 4:48 PM
To: Adamson, Ryan M.
Cc: hostap at shmoo.com
Subject: Re: EAP-Success = failure?

On Fri, 2008-01-11 at 14:39 -0500, Ryan M. Adamson wrote:
> Hello everyone,
> I'm running wpa_supplicant on RHEL5 using EAP-PEAP/MSCHAPv2 with a

Upstream wpa_supplicant, or the stock RHEL5 wpa_supplicant (0.4.8


> RADIUS server.  From what I can tell by looking at the debug logs on
> machine and the RADIUS server logs, authentication through the RADIUS
> server is successful.
> The 4-way handshake is failing, however, with:
> WPA: Failed to get master session key from EAPOL state machines
> WPA: Key handshake aborted
> A little bit earlier in the logs, I see this:
> EAPOL: Received EAP-Packet frame
> EAPOL: SUPP_BE entering state REQUEST
> EAPOL: getSuppRsp
> EAP: EAP entering state RECEIVED
> EAP: Received EAP-Success
> EAP: EAP entering state FAILURE
> CTRL-EVENT-EAP-FAILURE EAP authentication failed
> Can anyone shed any light on the situation?
> Thanks!
> Ryan Adamson
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list