hostAP and wds with madwifi

Micro Cool microcool
Wed Sep 26 08:07:06 PDT 2007

I did a little more investigation on my end and I found the following results that you in order for this to work I needed to use wireless extentions for wpa_supplicant and madwifi for hostap(I am using 2.6.19 of the kernel).  If I tried to load madwifi for both that was when I was getting the problems that I have been seeing.  Also in my case I was using an embedded system and thus I needed to load the 802.11 stack into the kernel directly for everything to work.
Thanks for your help,

Subject: RE: hostAP and wds with madwifiDate: Tue, 25 Sep 2007 23:15:28 -0700From: bsmith at road-inc.comTo: microcool at; hostap at

Looks like there are some bugs, maybe with the version combo.  Obviously some folks have got it working.  I've had cases where hostapd will cause listeners to have 5+ of the same AP in the scans.  This happens after launching wpa_supplicant.  This is different than how it acts on my laptop (2.6.16) vs 2.4.25 on this embedded device.  I get similar results to you with the linux 2.4.  I'll post my finding when I get this working.

From: Micro Cool [mailto:microcool at]Sent: Mon 9/24/2007 10:20 AMTo: Smith, Bruce; hostap at shmoo.comSubject: RE: hostAP and wds with madwifi
Thanks Bruce,     Can you tell me which version of madwifi, hostap, and wpa_supplicant you are using? Thanks,Joe

Subject: RE: hostAP and wds with madwifiDate: Mon, 24 Sep 2007 10:03:25 -0700From: bsmith at road-inc.comTo: microcool at; hostap at

I've used it in this mode although I am having an issue with moving data.
I first run wpa_supplicant on the sta intf and wait for association, then run hostapd on the other interface.  I then can see it from a second wifi card and can associate.  There was an issue with it not sending beacons but I don't remember the exact configuration but anytime I use this sequence it works fine.  
So the order of my bringup:
wlanconfig ath create wlandev wifi0 wlanmode ap
creates ath0
wlanconfig ath create wlandev wifi0 wlanmode sta nosbeacon
creates ath1
iwpriv ath0 wds 1
iwpriv ath1 wds 1
ifconfig ath0 up
ifconfig ath1 up
brctl addbr br0
brctl addif br0 ath0
brctl addif br0 ath1
brctl setfd br0 1
ifconfig br0
wpa_supplicant -Dmadwifi -iath1 -c /etc/wpa.conf
wait for association
hostapd /etc/hostapd.conf
I used a 2 wifi card at eth0 and ran wpa_supplicant on it to attach to the new AP defined in /etc/hostapd.conf.  You might try leaving ath0 down until wpa_supplicant is done then bring up ath0 and hostapd.  
I've also found the madwifi driver to be unstable, causing my machines to freeze.  Only in wds mode, otherwise the driver seems sound.

From: at on behalf of Micro CoolSent: Mon 9/24/2007 7:21 AMTo: hostap at shmoo.comSubject: hostAP and wds with madwifi
I am trying to get wpa_supplicant and hostapd to work for wds with the madwifi driver but I have not been having much luck.  I am aware that generally wds is not supported for 11i key managment method but since madwifi sets their wds links up as a station and a AP I thought it might be possible if you run hostAP on the AP interface and wpa_supplicant on the station interface.  However when I tried this for some reason whenever I bring the AP interface up with hostAP it never beacons.  Thought this was odd so I tried bringing the AP interface up first and then bring the station interface up and indeed the AP did beacon but as soon as the station linked it stopped. Does anyone have any thoughts why this is happening?  Thanks,Joe

Can you find the hidden words?  Take a break and play Seekadoo! Play now!

Can you find the hidden words?  Take a break and play Seekadoo! Play now!
Explore the seven wonders of the world
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list