WPA - AP association Issue

Bryan Kadzban bryan
Fri Oct 26 16:03:23 PDT 2007

Hash: RIPEMD160

Mr. Maloomnahi wrote:
> NetGear has provided the driver for the card for Windows (WG311T WLAN
> card) and after installation we tried to scan and activate the WLAN
> connection.
> After all the types of settings allowed, Only OPEN and SHARED
> authentication algorithm system worked and that too for 1 minute or
> so, like the source code based association happens.
> I could see similar connected status for that 1 minute and after that
> gets disassociated.
> Could this be a card issue or the authentication on hostapd issue? or
> source code (configuration) based AP problem. Later seems to be the
> main cause to me.

Depending on what was driving the association in Windows (i.e. was it
the Netgear software, or were you using XP and the XP wireless interface
code?), it may very well be an issue on the hostapd side.

Unfortunately I know very little about hostapd...

Also, from your earlier message:

> iwconfig ath0 essid "SEMCO_AP"
> iwconfig ath0 key XXXX open
> iwconfig ath0 frag 512 rts 40 rate 36M auto
> iwpriv ath0 wpa 1 keymgtalgs 2 hostroaming 1 dropunencrypted 0
> authmode 4
> ifconfig ath0 up
> iwconfig ath0 ap 00:14:78:8F:5E:49

Does it work if you skip all this?  If you run it while wpa_supplicant
is trying to do its thing, you might be interfering with the wireless
handling that wpa_supplicant does.  (Normally it controls the
association, etc.)

Of course if you run it before you start wpa_supplicant, then never
mind; I don't think it would interfere that way.

> [root at localhost wpa_supplicant-0.5.8]# wpa_supplicant <stuff>

Er, this ran your system's wpa_supplicant binary, not the one you just
built.  I also didn't see the extra wpa_printf()s in the output you had
pasted here.

To run the newly-compiled wpa_supplicant, stick a ./ in front of it.

./wpa_supplicant -Dmadwifi -iath0 -c EAP_TTLS_TKIP.conf -dd

should show you the extra messages I had you add.  :-)

(But if the issue is with hostapd, then I'm not sure this will help
anymore.  Still might be worth a shot.)

Actually, does it help if you remove all the WEP-related stuff (both the
WEP stuff in the config files and the "iwconfig ath0 key XXXX open")?
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Hostap mailing list