about adding stdio.h to Makefile of hostap

Nazeer Khan Nazeer.Khan
Sun Jul 22 18:43:29 PDT 2007

On Mon, July 23, 2007 1:53 am, YAN HE said:
> Hello, All,
> I changed hostap_80211_rx.c of hostap-driver-0.4.9 to support my own
> application. After I added "#include <stdio.h>", the program cannot be
> compiled successfully on Fedora 4 (Kernel 2.6.11). The error message shows
> that the file stdio.h is not found. Because this header file is under
> /usr/include, I added "CFLAGS += -I/usr/include" to Makefile. I also tried
> changing "INCLUDES=-I$(KERNEL_PATH)/include" to "INCLUDES=-I/usr/include
> -I$(KERNEL_PATH)/include". But stdio.h is still not found in either case.
> I did not find similar problems in the archive of hostap. Would you give
> me any advice if you have any idea? The Makefile of hostap-driver-0.4.9 is
> attached.

The user space libraries cannot be used for kernel space drivers.

I am not sure how to do that.

> Thank you very much.
> YAN  _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap


Nazeer Khan
Research Student
Networks and Pervasive Computing
National ICT Australia Limited
Phone: +61 2 8374 5554
Mobile: +61 415627442

The imagination driving Australia's ICT future.

More information about the Hostap mailing list