about adding stdio.h to Makefile of hostap

YAN HE yanhe
Sun Jul 22 08:53:22 PDT 2007

Hello, All,

I changed hostap_80211_rx.c of hostap-driver-0.4.9 to support my own application. After I added "#include <stdio.h>", the program cannot be compiled successfully on Fedora 4 (Kernel 2.6.11). The error message shows that the file stdio.h is not found. Because this header file is under /usr/include, I added "CFLAGS += -I/usr/include" to Makefile. I also tried changing "INCLUDES=-I$(KERNEL_PATH)/include" to "INCLUDES=-I/usr/include -I$(KERNEL_PATH)/include". But stdio.h is still not found in either case. I did not find similar problems in the archive of hostap. Would you give me any advice if you have any idea? The Makefile of hostap-driver-0.4.9 is attached.

Thank you very much.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20070722/1850c906/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Makefile
Type: application/octet-stream
Size: 6715 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20070722/1850c906/attachment.obj 

More information about the Hostap mailing list