Authentication times out at 4WAY_HANDSHAKE -> GROUP_HANDSHAKE

Sergey Krilov
Wed Aug 29 20:03:37 PDT 2007


I'm having trouble connecting to my wireless home network. I'm running
wpa_supplicant 0.5.8 on Ubuntu 7.04. My wireless card has the bcm43xx
chipset (specifically, it is the Broadcom 4321AG a/b/g/draft-n), and
I'm using the ndiswrapper 1.47 module. My router model is Belkin
F5D8231-4 v2.

The problem is that about 95% of the time, the authentication process
times out right after this line:


Furthermore, every time it fails, this line is present somewhere
within that trial:

WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)

I'm not really an expert at interpreting this, so I don't know if this
is significant. I am posting several links to the wpa_supplicant log
when I run it with the -d option. I broke up the log into several
files and added some newlines in the hope that it would be easier to
read and interpret, as well as compare side by side (with a program
like tkdiff) if necessary. The first file displays some preliminary
output from wpa_supplicant, the next 5 files represent the 5 times
that wpa_supplicant tried and failed to authenticate with the router.
They are very similar, but not identical. The 6th file shows what
success looks like.

The command I ran to start wpa_supplicant looked like this:
# wpa_supplicant -iwlan0 -Dwext -c/etc/wpa_supplicant.conf -d > wpa_problem.txt

And my wpa_supplicant.conf looks like this:


This does not appear to be a hardware problem -- on Windows (I'm
dual-booting), I have no trouble connecting.

Does anyone know why this happens? How can I go about solving this?

Thanks in advance for any help.

More information about the Hostap mailing list