[hostap driver] not authenticating when used w/ wpa-supplicant / network-manager

Dan Williams dcbw
Wed Aug 15 07:26:10 PDT 2007

On Tue, 2007-08-14 at 15:59 -0600, Andrew Jorgensen wrote:
> On 8/14/07, Andrew Jorgensen <andrew.jorgensen at gmail.com> wrote:
> > Also, in another thread you advised the user to use the wext driver
> > against hostap_*.  Is that the preferred driver for current versions
> > of hostap_*?  There's a patch in the Ubuntu network-manager that sets
> > the wpa-supplicant driver to hostap if the device driver is hostap_*.
> > They can try taking that out if it should work better.
> Using the wext driver doesn't appear to change anything.  Anything
> else I can do to debug this?
> Also, I've read reports elsewhere that wpa-supplicant has worked with
> the hostap driver and the 1.7.1 firmware.  Even more reports that it
> works with 1.5.6 firmware, which I have also tried.

Not really, you need more visiblity into the driver's behavior to figure
out why.  It could also be firmware and interaction with the access
point.  At some point you probably need to dig out an 802.11 frame
sniffer and observe the traffic between the AP and the card and make
sure the sequence matches up with what is expected.  You may be able to
get the driver to print out the return code from association if the AP
rejects association, which are standard codes in 802.11 that could give
you a hint.  Otherwise it could be buried in the firmware.  Do other
cards work?


More information about the Hostap mailing list