No WPA on Ubuntu feisty with precompiled hostap_pci

Malte Cornils malte
Tue Aug 14 16:11:10 PDT 2007

Am Dienstag, 14. August 2007 19:20 schrieb Tony Espy:
> Malte Cornils wrote:
> > I tried setting up WPA for a friend of mine via a remote debugging
> > session. He has a
> >
> > 00:09.0 Network controller: Intersil Corporation Prism 2.5 Wavelan
> > chipset (rev 01)
> > built-in card.
> >
> > wpa_supplicant does not want to associate:
> >
> > [ 7593.068000] hostap_pci: Registered netdevice wifi0
> > [ 7593.068000] wifi0: Original COR value: 0x0
> > [ 7593.280000] prism2_hw_init: initialized in 200 ms
> > [ 7593.280000] wifi0: NIC: id=0x8013 v1.0.0
> > [ 7593.284000] wifi0: PRI: id=0x15 v1.1.0
> > [ 7593.284000] wifi0: STA: id=0x1f v1.4.9
> i think your problem is that the STA firmware you're using doesn't
> support WPA.  you need to upgrade it to v1.7.4.


Yep, that was it. Actually, I tried upgrading the firmware already, but on 
Ubuntu feisty, the PDA information could not be read. Passing 
the -O  /proc/net/hostap/wlan0/pda flag made the upgrade work finally (even 
though the interface is called wlan1 on the system). I used the 1.8.2 
firmware revision.

There are still some bugs - rmmoding the hostap_pci driver now grinds the 
system to a halt, and the first ifup doesn not get a DHCPOFFER. Ubuntu's 
Network Manager still does not offer WPA, only WEP. ifdown'ing the interface 
and putting it up again results in a succesful connection, though, and my 
friend is happy with not rmmod'ing hostap_pci ever :-) So, thanks from him 
and me to you!

BTW, we're using the wext interface and it works fine now.

Thanks a lot! And BTW, 15 minutes time from asking the question to a solution 
is an impressive turn-around time!

-Malte Cornils

More information about the Hostap mailing list