wpa_supplicant + hostapd + RADIUS --> NO WPA/RSN IE

Andrea G. Forte andreaf
Sun Feb 5 16:55:03 PST 2006

Dear all,

I am having problems when trying to use wpa_supplicant + hostap-driver + 
hostapd + external radius server (freeradius). The versions of these are 
all 0.4.7.
The problem that I get is (SSID is test):

aa:cc:dd:ee:dd:cc ssid='test' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
 skip - no WPA/RSN  IE

I have attached the two config files of hostapd and wpa_supplicant. Also 
the communication between hostapd and freeradius works. On the other 
hand, I have used the wpa_supplicant with a real AP (not with hostap 
running on my laptop) and with WPA-PSK it worked. This makes me think 
that the problem has to be in hostapd somehow. I have tried to add 
scan_ssid=1 in the config file of hostapd as I read a few comments in 
previous emails but it did not help.

Any idea on what might be wrong?

Thanks a lot,

wpa_supplicant.conf in the next email.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: hostapd.conf
Url: http://lists.shmoo.com/pipermail/hostap/attachments/20060205/3a838abb/attachment.txt 

More information about the Hostap mailing list