D-Link DRC-650 and wpa_supplicant fails

Alberto Venturini venturini
Mon Dec 25 03:37:51 PST 2006

I've bought a D-Link DRC-650 wifi pc-card (AKA D-Link "Neteasy"), and
I want to use it in a WPA-PSK environment. I'm trying to get it
working with wpa_supplicant, but I haven't had much success so far.

My first doubt is the driver: this card has a PrismII chipset, so I
think the hostap driver is fine. But when I plug the card in, the udev
subsystem loads both hostap_cs and orinoco_cs modules. I'm a bit
confused: why are two drivers loaded? I'm using a kernel; the
distribution is Archlinux.

Anyway, the card is identified, and when I do "iwconfig", both
wlan0 and wifi0 interfaces are listed. Now, I want to run
wpa_supplicant, and I run these commands:

[root at vega ~]# iwconfig wlan0 mode managed
[root at vega ~]# ifconfig wlan0 up
[root at vega ~]# wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported

and it hangs here. I'm stuck at this point: how can I get
wpa_supplicant to work with this card? I also tried to blacklist the
orinoco* modules, so only the hostap_cs module is loaded, but I get the
same error message from wpa_supplicant.

Thank you for any suggestions.


More information about the Hostap mailing list