HostAP and WPA2 with Intersil Prism card

Alex Pounds alex
Tue Dec 19 07:11:40 PST 2006

On Mon, December 18, 2006 3:17 pm, Dave Neuer wrote:
> On 12/18/06, Aaron Baillargeon <abaillargeon at> wrote:
>> Alex Pounds wrote:
>> > I've downgraded to 1.7.4, but I have exactly the same problem as before.
>> > Debugging output with -dd from wpa_supplicant is pretty much identical
>> > (sometimes it receives 3 BSSIDs instead of 1 from the previous session).
>> Just from staring at these for a couple days, the debug output seems
>> like it might be a config error on either the authentication server or
>> the client. From the log it seems you're using wpa2-psk/ccmp?, have you
>> tried wpa-psk/tkip or other configs and gotten them to work?
> FWIW, I'm using TKIP only, and I have the same problem. I did find
> that when I connect w/ a static-style startup script, I can't connect
> long enough to use the connection at all.

I had a play last night with different methods, but got the same result for
all of them. I also fiddled with the config options, but I believe the
wpa_supplicant defaults are quite permissive and the options are more for
restricting the program to certain methods.

My router (A Linksys - I think it's called a "WRT54TG", though I'm not sure)
offers two options that look good - WPA Personal and WPA2 Personal. IT also
offers an Enterprise option for these, but I don't have a RADIUS server so
that seems irrelevant. For WPA Personal I can choose between AES and TKIP;
WPA2 offers "AES" and "AES+TKIP", which I understand actually means "Use AES
if you can, fall back to TKIP if you can't."

Anyway, I tried all four options, but I still got my associated/unassociated
flip-flopping described previously. As I say, my desktop PC can connect
fine, so I'm really not sure where the problem lies - either with the hostap
driver or the wifi card itself, I suppose (my desktop is not prism-based).

So, what now? Is there some more debugging output I can provide to try and
nail down the problem more? Is there an alternative (ndiswrapper?) I can use
that may work and get me using WPA2 with this access point?

Thank you,

Alex Pounds (Creature)                  .~.
                                       // \\
"Variables won't; Constants aren't"   /(   )\

More information about the Hostap mailing list