HostAP and WPA2 with Intersil Prism card

Dave Neuer mr.fred.smoothie
Mon Dec 18 07:17:21 PST 2006

On 12/18/06, Aaron Baillargeon <abaillargeon at> wrote:
> Alex Pounds wrote:
> >
> > I've downgraded to 1.7.4, but I have exactly the same problem as before.
> > Debugging output with -dd from wpa_supplicant is pretty much identical
> > (sometimes it receives 3 BSSIDs instead of 1 from the previous session).
> >
> > Any other ideas?
> >
> >
> Just from staring at these for a couple days, the debug output seems
> like it might be a config error on either the authentication server or
> the client. From the log it seems you're using wpa2-psk/ccmp?, have you
> tried wpa-psk/tkip or other configs and gotten them to work?

FWIW, I'm using TKIP only, and I have the same problem. I did find
that when I connect w/ a static-style startup script, I can't connect
long enough to use the connection at all.

I've started doing wpa_supplicant -B -C
/path-to-global-control-interface, and then using NetworkManager to
connect to the AP. It's still fairly unstable, but not unusably so. I
end up just having to toggle the wireless interface when I notice the
network has become unresponsive.

However, my office is also our guest bedroom and we have holiday visitors, so
1) I haven't tried connecting with the machine in question since I
move my AP closer to said machine, and;
2) I won't really be able to access it to check the logs or the config
in detail until after Christmas.

At any rate, some amount of instability seems at this point to be
somewhat unavoidable in my setup (unless I win the lottery or get
snowbound, or some other magic event happens which provides me w/ the
amount of free time that would be necessary for me to poke around the
internals enough to really understand what's happening at a lower


More information about the Hostap mailing list